Direwolf20 Modpack

It has come to our attention that the Direwolf20 Modpack has updated again today. It has been pushed up to version 5.0.1. If you want to be able to play on the Peacecraft Modded Server do not update to this version as it is incompatible with the version currently on the server. It really should have been called version 6.0.0 for how much has changed in it. To make matters worse, this time it is not possible to downgrade to the previous version so if you update you are stuck until we can update the server again, which will probably happen this coming weekend as long as there are no surprises.
Sign In or Register to comment.